10
In this guide, we are going to see how to install the latest version of Grub Customizer (currently 4.0.6) on Debian 8/7 (Jessie and Wheezy). As you know, Grub Customizer is a tool with GUI that allows users to configure Grub2 or BURG boot loader settings.


Grub Customizer 4.0.6 Installation

To install Grub Customizer 4.0.6 on Debian 8 and Debian 7, write these commands on the terminal:

su - 
apt-get install build-essential cmake libgtkmm-3.0-dev libssl-dev gettext libarchive-dev 
wget https://goo.gl/qQnUhK -O grub-customizer_4.0.6.tar.gz 
tar xfv grub-customi* 
cd grub-customi* 
cmake . && make -j3 
make install

You can then start Grub Customizer using this command:

grub-customizer

Grub Customizer Removal (Optional)

To uninstall Grub Customizer from your system, run these commands:

su - 
wget https://goo.gl/qQnUhK -O grub-customizer_4.0.6.tar.gz 
tar xfv grub-customi* 
cd grub-customi* 
make uninstall

Post a Comment

  1. Thanks for share .Follow you..

    ReplyDelete
  2. Uauh, thanks. I installed in Kali and grub-customizer 5.0.6

    ReplyDelete
  3. This comment has been removed by the author.

    ReplyDelete
  4. i'm getting this error when i run grub-customizer

    No protocol specified

    ** (grub-customizer:11992): WARNING **: Could not open X display
    No protocol specified
    Unable to init server: Could not connect: Connection refused

    (grub-customizer:11992): Gtk-WARNING **: cannot open display: :0


    any ideas how to solve it? It didn't throw any errors on make install

    ReplyDelete
  5. This comment has been removed by the author.

    ReplyDelete
  6. Hello. I've got libarchive13 installed and have an error:
    This package is uninstallable
    Dependency is not satisfiable: libarchive12
    Do you have any idea? Thanks, Jim

    ReplyDelete
  7. Small suggestion ;
    # cd grub-customi*
    output:-bash: cd: too many arguments
    ----------
    # cd grub-customizer-4.0.6/
    ----------
    Debian Sid
    ---
    Thanks for sharing

    ReplyDelete

 
Top